Browse code

chore: Upgrade dependencies

Payson Wallach authored on 23/03/2022 20:09:58
Showing 2 changed files

... ...
@@ -35,12 +35,12 @@
35 35
         "@commitlint/cli": "^16.2.3",
36 36
         "@commitlint/config-conventional": "^16.2.1",
37 37
         "@types/progressbar.js": "^1.1.2",
38
-        "@types/react": "^17.0.41",
38
+        "@types/react": "^17.0.42",
39 39
         "@types/react-dom": "^17.0.14",
40 40
         "@typescript-eslint/eslint-plugin": "^5.16.0",
41 41
         "@typescript-eslint/parser": "^5.16.0",
42 42
         "autoprefixer": "^10.4.4",
43
-        "babel-loader": "^8.2.3",
43
+        "babel-loader": "^8.2.4",
44 44
         "babel-plugin-parameter-decorator": "^1.0.16",
45 45
         "babel-plugin-transform-typescript-metadata": "^0.3.2",
46 46
         "chrome-webstore-upload-cli": "^2.0.1",
... ...
@@ -2764,9 +2764,9 @@
2764 2764
       "dev": true
2765 2765
     },
2766 2766
     "node_modules/@types/react": {
2767
-      "version": "17.0.41",
2768
-      "resolved": "https://registry.npmjs.org/@types/react/-/react-17.0.41.tgz",
2769
-      "integrity": "sha512-chYZ9ogWUodyC7VUTRBfblysKLjnohhFY9bGLwvnUFFy48+vB9DikmB3lW0qTFmBcKSzmdglcvkHK71IioOlDA==",
2767
+      "version": "17.0.42",
2768
+      "resolved": "https://registry.npmjs.org/@types/react/-/react-17.0.42.tgz",
2769
+      "integrity": "sha512-nuab3x3CpJ7VFeNA+3HTUuEkvClYHXqWtWd7Ud6AZYW7Z3NH9WKtgU+tFB0ZLcHq+niB/HnzLcaZPqMJ95+k5Q==",
2770 2770
       "dev": true,
2771 2771
       "dependencies": {
2772 2772
         "@types/prop-types": "*",
... ...
@@ -4076,13 +4076,13 @@
4076 4076
       }
4077 4077
     },
4078 4078
     "node_modules/babel-loader": {
4079
-      "version": "8.2.3",
4080
-      "resolved": "https://registry.npmjs.org/babel-loader/-/babel-loader-8.2.3.tgz",
4081
-      "integrity": "sha512-n4Zeta8NC3QAsuyiizu0GkmRcQ6clkV9WFUnUf1iXP//IeSKbWjofW3UHyZVwlOB4y039YQKefawyTn64Zwbuw==",
4079
+      "version": "8.2.4",
4080
+      "resolved": "https://registry.npmjs.org/babel-loader/-/babel-loader-8.2.4.tgz",
4081
+      "integrity": "sha512-8dytA3gcvPPPv4Grjhnt8b5IIiTcq/zeXOPk4iTYI0SVXcsmuGg7JtBRDp8S9X+gJfhQ8ektjXZlDu1Bb33U8A==",
4082 4082
       "dev": true,
4083 4083
       "dependencies": {
4084 4084
         "find-cache-dir": "^3.3.1",
4085
-        "loader-utils": "^1.4.0",
4085
+        "loader-utils": "^2.0.0",
4086 4086
         "make-dir": "^3.1.0",
4087 4087
         "schema-utils": "^2.6.5"
4088 4088
       },
... ...
@@ -4094,32 +4094,6 @@
4094 4094
         "webpack": ">=2"
4095 4095
       }
4096 4096
     },
4097
-    "node_modules/babel-loader/node_modules/json5": {
4098
-      "version": "1.0.1",
4099
-      "resolved": "https://registry.npmjs.org/json5/-/json5-1.0.1.tgz",
4100
-      "integrity": "sha512-aKS4WQjPenRxiQsC93MNfjx+nbF4PAdYzmd/1JIj8HYzqfbu86beTuNgXDzPknWk0n0uARlyewZo4s++ES36Ow==",
4101
-      "dev": true,
4102
-      "dependencies": {
4103
-        "minimist": "^1.2.0"
4104
-      },
4105
-      "bin": {
4106
-        "json5": "lib/cli.js"
4107
-      }
4108
-    },
4109
-    "node_modules/babel-loader/node_modules/loader-utils": {
4110
-      "version": "1.4.0",
4111
-      "resolved": "https://registry.npmjs.org/loader-utils/-/loader-utils-1.4.0.tgz",
4112
-      "integrity": "sha512-qH0WSMBtn/oHuwjy/NucEgbx5dbxxnxup9s4PVXJUDHZBQY+s0NWA9rJf53RBnQZxfch7euUui7hpoAPvALZdA==",
4113
-      "dev": true,
4114
-      "dependencies": {
4115
-        "big.js": "^5.2.2",
4116
-        "emojis-list": "^3.0.0",
4117
-        "json5": "^1.0.1"
4118
-      },
4119
-      "engines": {
4120
-        "node": ">=4.0.0"
4121
-      }
4122
-    },
4123 4097
     "node_modules/babel-loader/node_modules/schema-utils": {
4124 4098
       "version": "2.7.1",
4125 4099
       "resolved": "https://registry.npmjs.org/schema-utils/-/schema-utils-2.7.1.tgz",
... ...
@@ -19537,9 +19511,9 @@
19537 19511
       "dev": true
19538 19512
     },
19539 19513
     "@types/react": {
19540
-      "version": "17.0.41",
19541
-      "resolved": "https://registry.npmjs.org/@types/react/-/react-17.0.41.tgz",
19542
-      "integrity": "sha512-chYZ9ogWUodyC7VUTRBfblysKLjnohhFY9bGLwvnUFFy48+vB9DikmB3lW0qTFmBcKSzmdglcvkHK71IioOlDA==",
19514
+      "version": "17.0.42",
19515
+      "resolved": "https://registry.npmjs.org/@types/react/-/react-17.0.42.tgz",
19516
+      "integrity": "sha512-nuab3x3CpJ7VFeNA+3HTUuEkvClYHXqWtWd7Ud6AZYW7Z3NH9WKtgU+tFB0ZLcHq+niB/HnzLcaZPqMJ95+k5Q==",
19543 19517
       "dev": true,
19544 19518
       "requires": {
19545 19519
         "@types/prop-types": "*",
... ...
@@ -20536,37 +20510,17 @@
20536 20510
       }
20537 20511
     },
20538 20512
     "babel-loader": {
20539
-      "version": "8.2.3",
20540
-      "resolved": "https://registry.npmjs.org/babel-loader/-/babel-loader-8.2.3.tgz",
20541
-      "integrity": "sha512-n4Zeta8NC3QAsuyiizu0GkmRcQ6clkV9WFUnUf1iXP//IeSKbWjofW3UHyZVwlOB4y039YQKefawyTn64Zwbuw==",
20513
+      "version": "8.2.4",
20514
+      "resolved": "https://registry.npmjs.org/babel-loader/-/babel-loader-8.2.4.tgz",
20515
+      "integrity": "sha512-8dytA3gcvPPPv4Grjhnt8b5IIiTcq/zeXOPk4iTYI0SVXcsmuGg7JtBRDp8S9X+gJfhQ8ektjXZlDu1Bb33U8A==",
20542 20516
       "dev": true,
20543 20517
       "requires": {
20544 20518
         "find-cache-dir": "^3.3.1",
20545
-        "loader-utils": "^1.4.0",
20519
+        "loader-utils": "^2.0.0",
20546 20520
         "make-dir": "^3.1.0",
20547 20521
         "schema-utils": "^2.6.5"
20548 20522
       },
20549 20523
       "dependencies": {
20550
-        "json5": {
20551
-          "version": "1.0.1",
20552
-          "resolved": "https://registry.npmjs.org/json5/-/json5-1.0.1.tgz",
20553
-          "integrity": "sha512-aKS4WQjPenRxiQsC93MNfjx+nbF4PAdYzmd/1JIj8HYzqfbu86beTuNgXDzPknWk0n0uARlyewZo4s++ES36Ow==",
20554
-          "dev": true,
20555
-          "requires": {
20556
-            "minimist": "^1.2.0"
20557
-          }
20558
-        },
20559
-        "loader-utils": {
20560
-          "version": "1.4.0",
20561
-          "resolved": "https://registry.npmjs.org/loader-utils/-/loader-utils-1.4.0.tgz",
20562
-          "integrity": "sha512-qH0WSMBtn/oHuwjy/NucEgbx5dbxxnxup9s4PVXJUDHZBQY+s0NWA9rJf53RBnQZxfch7euUui7hpoAPvALZdA==",
20563
-          "dev": true,
20564
-          "requires": {
20565
-            "big.js": "^5.2.2",
20566
-            "emojis-list": "^3.0.0",
20567
-            "json5": "^1.0.1"
20568
-          }
20569
-        },
20570 20524
         "schema-utils": {
20571 20525
           "version": "2.7.1",
20572 20526
           "resolved": "https://registry.npmjs.org/schema-utils/-/schema-utils-2.7.1.tgz",
... ...
@@ -59,12 +59,12 @@
59 59
     "@commitlint/cli": "^16.2.3",
60 60
     "@commitlint/config-conventional": "^16.2.1",
61 61
     "@types/progressbar.js": "^1.1.2",
62
-    "@types/react": "^17.0.41",
62
+    "@types/react": "^17.0.42",
63 63
     "@types/react-dom": "^17.0.14",
64 64
     "@typescript-eslint/eslint-plugin": "^5.16.0",
65 65
     "@typescript-eslint/parser": "^5.16.0",
66 66
     "autoprefixer": "^10.4.4",
67
-    "babel-loader": "^8.2.3",
67
+    "babel-loader": "^8.2.4",
68 68
     "babel-plugin-parameter-decorator": "^1.0.16",
69 69
     "babel-plugin-transform-typescript-metadata": "^0.3.2",
70 70
     "chrome-webstore-upload-cli": "^2.0.1",