Browse code

chore: Upgrade dependencies

Payson Wallach authored on 16/03/2022 19:25:20
Showing 2 changed files

... ...
@@ -9,11 +9,11 @@
9 9
       "version": "0.2.0",
10 10
       "license": "GPL-3.0",
11 11
       "devDependencies": {
12
-        "@commitlint/cli": "^16.2.1",
12
+        "@commitlint/cli": "^16.2.3",
13 13
         "@commitlint/config-conventional": "^16.2.1",
14 14
         "husky": "^7.0.4",
15 15
         "npm-run-all": "^4.1.5",
16
-        "prettier": "^2.5.1",
16
+        "prettier": "^2.6.0",
17 17
         "prettier-package-json": "^2.6.3",
18 18
         "scrivano": "^0.1.0",
19 19
         "standard-version": "^9.3.2"
... ...
@@ -99,14 +99,14 @@
99 99
       }
100 100
     },
101 101
     "node_modules/@commitlint/cli": {
102
-      "version": "16.2.1",
103
-      "resolved": "https://registry.npmjs.org/@commitlint/cli/-/cli-16.2.1.tgz",
104
-      "integrity": "sha512-zfKf+B9osuiDbxGMJ7bWFv7XFCW8wlQYPtCffNp7Ukdb7mdrep5R9e03vPUZysnwp8NX6hg05kPEvnD/wRIGWw==",
102
+      "version": "16.2.3",
103
+      "resolved": "https://registry.npmjs.org/@commitlint/cli/-/cli-16.2.3.tgz",
104
+      "integrity": "sha512-VsJBQLvhhlOgEfxs/Z5liYuK0dXqLE5hz1VJzLBxiOxG31kL/X5Q4OvK292BmO7IGZcm1yJE3XQPWSiFaEHbWA==",
105 105
       "dev": true,
106 106
       "dependencies": {
107 107
         "@commitlint/format": "^16.2.1",
108 108
         "@commitlint/lint": "^16.2.1",
109
-        "@commitlint/load": "^16.2.1",
109
+        "@commitlint/load": "^16.2.3",
110 110
         "@commitlint/read": "^16.2.1",
111 111
         "@commitlint/types": "^16.2.1",
112 112
         "lodash": "^4.17.19",
... ...
@@ -228,9 +228,9 @@
228 228
       }
229 229
     },
230 230
     "node_modules/@commitlint/load": {
231
-      "version": "16.2.1",
232
-      "resolved": "https://registry.npmjs.org/@commitlint/load/-/load-16.2.1.tgz",
233
-      "integrity": "sha512-oSpz0jTyVI/A1AIImxJINTLDOMB8YF7lWGm+Jg5wVWM0r7ucpuhyViVvpSRTgvL0z09oIxlctyFGWUQQpI42uw==",
231
+      "version": "16.2.3",
232
+      "resolved": "https://registry.npmjs.org/@commitlint/load/-/load-16.2.3.tgz",
233
+      "integrity": "sha512-Hb4OUlMnBUK6UxJEZ/VJ5k0LocIS7PtEMbRXEAA7eSpOgORIFexC4K/RaRpVd5UTtu3M0ST3ddPPijF9rdW6nw==",
234 234
       "dev": true,
235 235
       "dependencies": {
236 236
         "@commitlint/config-validator": "^16.2.1",
... ...
@@ -465,9 +465,9 @@
465 465
       "dev": true
466 466
     },
467 467
     "node_modules/@types/node": {
468
-      "version": "17.0.17",
469
-      "resolved": "https://registry.npmjs.org/@types/node/-/node-17.0.17.tgz",
470
-      "integrity": "sha512-e8PUNQy1HgJGV3iU/Bp2+D/DXh3PYeyli8LgIwsQcs1Ar1LoaWHSIT6Rw+H2rNJmiq6SNWiDytfx8+gYj7wDHw==",
468
+      "version": "17.0.21",
469
+      "resolved": "https://registry.npmjs.org/@types/node/-/node-17.0.21.tgz",
470
+      "integrity": "sha512-DBZCJbhII3r90XbQxI8Y9IjjiiOGlZ0Hr32omXIZvwwZ7p4DMMXGrKXVyPfuoBOri9XNtL0UK69jYIBIsRX3QQ==",
471 471
       "dev": true
472 472
     },
473 473
     "node_modules/@types/normalize-package-data": {
... ...
@@ -1261,13 +1261,13 @@
1261 1261
       }
1262 1262
     },
1263 1263
     "node_modules/cosmiconfig-typescript-loader": {
1264
-      "version": "1.0.5",
1265
-      "resolved": "https://registry.npmjs.org/cosmiconfig-typescript-loader/-/cosmiconfig-typescript-loader-1.0.5.tgz",
1266
-      "integrity": "sha512-FL/YR1nb8hyN0bAcP3MBaIoZravfZtVsN/RuPnoo6UVjqIrDxSNIpXHCGgJe0ZWy5yImpyD6jq5wCJ5f1nUv8g==",
1264
+      "version": "1.0.6",
1265
+      "resolved": "https://registry.npmjs.org/cosmiconfig-typescript-loader/-/cosmiconfig-typescript-loader-1.0.6.tgz",
1266
+      "integrity": "sha512-2nEotziYJWtNtoTjKbchj9QrdTT6DBxCvqjNKoDKARw+e2yZmTQCa07uRrykLIZuvSgp69YXLH89UHc0WhdMfQ==",
1267 1267
       "dev": true,
1268 1268
       "dependencies": {
1269 1269
         "cosmiconfig": "^7",
1270
-        "ts-node": "^10.5.0"
1270
+        "ts-node": "^10.6.0"
1271 1271
       },
1272 1272
       "engines": {
1273 1273
         "node": ">=12",
... ...
@@ -3125,15 +3125,18 @@
3125 3125
       }
3126 3126
     },
3127 3127
     "node_modules/prettier": {
3128
-      "version": "2.5.1",
3129
-      "resolved": "https://registry.npmjs.org/prettier/-/prettier-2.5.1.tgz",
3130
-      "integrity": "sha512-vBZcPRUR5MZJwoyi3ZoyQlc1rXeEck8KgeC9AwwOn+exuxLxq5toTRDTSaVrXHxelDMHy9zlicw8u66yxoSUFg==",
3128
+      "version": "2.6.0",
3129
+      "resolved": "https://registry.npmjs.org/prettier/-/prettier-2.6.0.tgz",
3130
+      "integrity": "sha512-m2FgJibYrBGGgQXNzfd0PuDGShJgRavjUoRCw1mZERIWVSXF0iLzLm+aOqTAbLnC3n6JzUhAA8uZnFVghHJ86A==",
3131 3131
       "dev": true,
3132 3132
       "bin": {
3133 3133
         "prettier": "bin-prettier.js"
3134 3134
       },
3135 3135
       "engines": {
3136 3136
         "node": ">=10.13.0"
3137
+      },
3138
+      "funding": {
3139
+        "url": "https://github.com/prettier/prettier?sponsor=1"
3137 3140
       }
3138 3141
     },
3139 3142
     "node_modules/prettier-package-json": {
... ...
@@ -3862,9 +3865,9 @@
3862 3865
       }
3863 3866
     },
3864 3867
     "node_modules/ts-node": {
3865
-      "version": "10.5.0",
3866
-      "resolved": "https://registry.npmjs.org/ts-node/-/ts-node-10.5.0.tgz",
3867
-      "integrity": "sha512-6kEJKwVxAJ35W4akuiysfKwKmjkbYxwQMTBaAxo9KKAx/Yd26mPUyhGz3ji+EsJoAgrLqVsYHNuuYwQe22lbtw==",
3868
+      "version": "10.7.0",
3869
+      "resolved": "https://registry.npmjs.org/ts-node/-/ts-node-10.7.0.tgz",
3870
+      "integrity": "sha512-TbIGS4xgJoX2i3do417KSaep1uRAW/Lu+WAL2doDHC0D6ummjirVOXU5/7aiZotbQ5p1Zp9tP7U6cYhA0O7M8A==",
3868 3871
       "dev": true,
3869 3872
       "dependencies": {
3870 3873
         "@cspotcode/source-map-support": "0.7.0",
... ...
@@ -3884,6 +3887,7 @@
3884 3887
       "bin": {
3885 3888
         "ts-node": "dist/bin.js",
3886 3889
         "ts-node-cwd": "dist/bin-cwd.js",
3890
+        "ts-node-esm": "dist/bin-esm.js",
3887 3891
         "ts-node-script": "dist/bin-script.js",
3888 3892
         "ts-node-transpile-only": "dist/bin-transpile.js",
3889 3893
         "ts-script": "dist/bin-script-deprecated.js"
... ...
@@ -3920,9 +3924,9 @@
3920 3924
       "dev": true
3921 3925
     },
3922 3926
     "node_modules/typescript": {
3923
-      "version": "4.5.5",
3924
-      "resolved": "https://registry.npmjs.org/typescript/-/typescript-4.5.5.tgz",
3925
-      "integrity": "sha512-TCTIul70LyWe6IJWT8QSYeA54WQe8EjQFU4wY52Fasj5UKx88LNYKCgBEHcOMOrFF1rKGbD8v/xcNWVUq9SymA==",
3927
+      "version": "4.6.2",
3928
+      "resolved": "https://registry.npmjs.org/typescript/-/typescript-4.6.2.tgz",
3929
+      "integrity": "sha512-HM/hFigTBHZhLXshn9sN37H085+hQGeJHJ/X7LpBWLID/fbc2acUMfU+lGD98X81sKP+pFa9f0DZmCwB9GnbAg==",
3926 3930
       "dev": true,
3927 3931
       "bin": {
3928 3932
         "tsc": "bin/tsc",
... ...
@@ -4164,14 +4168,14 @@
4164 4168
       }
4165 4169
     },
4166 4170
     "@commitlint/cli": {
4167
-      "version": "16.2.1",
4168
-      "resolved": "https://registry.npmjs.org/@commitlint/cli/-/cli-16.2.1.tgz",
4169
-      "integrity": "sha512-zfKf+B9osuiDbxGMJ7bWFv7XFCW8wlQYPtCffNp7Ukdb7mdrep5R9e03vPUZysnwp8NX6hg05kPEvnD/wRIGWw==",
4171
+      "version": "16.2.3",
4172
+      "resolved": "https://registry.npmjs.org/@commitlint/cli/-/cli-16.2.3.tgz",
4173
+      "integrity": "sha512-VsJBQLvhhlOgEfxs/Z5liYuK0dXqLE5hz1VJzLBxiOxG31kL/X5Q4OvK292BmO7IGZcm1yJE3XQPWSiFaEHbWA==",
4170 4174
       "dev": true,
4171 4175
       "requires": {
4172 4176
         "@commitlint/format": "^16.2.1",
4173 4177
         "@commitlint/lint": "^16.2.1",
4174
-        "@commitlint/load": "^16.2.1",
4178
+        "@commitlint/load": "^16.2.3",
4175 4179
         "@commitlint/read": "^16.2.1",
4176 4180
         "@commitlint/types": "^16.2.1",
4177 4181
         "lodash": "^4.17.19",
... ...
@@ -4265,9 +4269,9 @@
4265 4269
       }
4266 4270
     },
4267 4271
     "@commitlint/load": {
4268
-      "version": "16.2.1",
4269
-      "resolved": "https://registry.npmjs.org/@commitlint/load/-/load-16.2.1.tgz",
4270
-      "integrity": "sha512-oSpz0jTyVI/A1AIImxJINTLDOMB8YF7lWGm+Jg5wVWM0r7ucpuhyViVvpSRTgvL0z09oIxlctyFGWUQQpI42uw==",
4272
+      "version": "16.2.3",
4273
+      "resolved": "https://registry.npmjs.org/@commitlint/load/-/load-16.2.3.tgz",
4274
+      "integrity": "sha512-Hb4OUlMnBUK6UxJEZ/VJ5k0LocIS7PtEMbRXEAA7eSpOgORIFexC4K/RaRpVd5UTtu3M0ST3ddPPijF9rdW6nw==",
4271 4275
       "dev": true,
4272 4276
       "requires": {
4273 4277
         "@commitlint/config-validator": "^16.2.1",
... ...
@@ -4447,9 +4451,9 @@
4447 4451
       "dev": true
4448 4452
     },
4449 4453
     "@types/node": {
4450
-      "version": "17.0.17",
4451
-      "resolved": "https://registry.npmjs.org/@types/node/-/node-17.0.17.tgz",
4452
-      "integrity": "sha512-e8PUNQy1HgJGV3iU/Bp2+D/DXh3PYeyli8LgIwsQcs1Ar1LoaWHSIT6Rw+H2rNJmiq6SNWiDytfx8+gYj7wDHw==",
4454
+      "version": "17.0.21",
4455
+      "resolved": "https://registry.npmjs.org/@types/node/-/node-17.0.21.tgz",
4456
+      "integrity": "sha512-DBZCJbhII3r90XbQxI8Y9IjjiiOGlZ0Hr32omXIZvwwZ7p4DMMXGrKXVyPfuoBOri9XNtL0UK69jYIBIsRX3QQ==",
4453 4457
       "dev": true
4454 4458
     },
4455 4459
     "@types/normalize-package-data": {
... ...
@@ -5062,13 +5066,13 @@
5062 5066
       }
5063 5067
     },
5064 5068
     "cosmiconfig-typescript-loader": {
5065
-      "version": "1.0.5",
5066
-      "resolved": "https://registry.npmjs.org/cosmiconfig-typescript-loader/-/cosmiconfig-typescript-loader-1.0.5.tgz",
5067
-      "integrity": "sha512-FL/YR1nb8hyN0bAcP3MBaIoZravfZtVsN/RuPnoo6UVjqIrDxSNIpXHCGgJe0ZWy5yImpyD6jq5wCJ5f1nUv8g==",
5069
+      "version": "1.0.6",
5070
+      "resolved": "https://registry.npmjs.org/cosmiconfig-typescript-loader/-/cosmiconfig-typescript-loader-1.0.6.tgz",
5071
+      "integrity": "sha512-2nEotziYJWtNtoTjKbchj9QrdTT6DBxCvqjNKoDKARw+e2yZmTQCa07uRrykLIZuvSgp69YXLH89UHc0WhdMfQ==",
5068 5072
       "dev": true,
5069 5073
       "requires": {
5070 5074
         "cosmiconfig": "^7",
5071
-        "ts-node": "^10.5.0"
5075
+        "ts-node": "^10.6.0"
5072 5076
       }
5073 5077
     },
5074 5078
     "create-require": {
... ...
@@ -6416,9 +6420,9 @@
6416 6420
       }
6417 6421
     },
6418 6422
     "prettier": {
6419
-      "version": "2.5.1",
6420
-      "resolved": "https://registry.npmjs.org/prettier/-/prettier-2.5.1.tgz",
6421
-      "integrity": "sha512-vBZcPRUR5MZJwoyi3ZoyQlc1rXeEck8KgeC9AwwOn+exuxLxq5toTRDTSaVrXHxelDMHy9zlicw8u66yxoSUFg==",
6423
+      "version": "2.6.0",
6424
+      "resolved": "https://registry.npmjs.org/prettier/-/prettier-2.6.0.tgz",
6425
+      "integrity": "sha512-m2FgJibYrBGGgQXNzfd0PuDGShJgRavjUoRCw1mZERIWVSXF0iLzLm+aOqTAbLnC3n6JzUhAA8uZnFVghHJ86A==",
6422 6426
       "dev": true
6423 6427
     },
6424 6428
     "prettier-package-json": {
... ...
@@ -6982,9 +6986,9 @@
6982 6986
       "dev": true
6983 6987
     },
6984 6988
     "ts-node": {
6985
-      "version": "10.5.0",
6986
-      "resolved": "https://registry.npmjs.org/ts-node/-/ts-node-10.5.0.tgz",
6987
-      "integrity": "sha512-6kEJKwVxAJ35W4akuiysfKwKmjkbYxwQMTBaAxo9KKAx/Yd26mPUyhGz3ji+EsJoAgrLqVsYHNuuYwQe22lbtw==",
6989
+      "version": "10.7.0",
6990
+      "resolved": "https://registry.npmjs.org/ts-node/-/ts-node-10.7.0.tgz",
6991
+      "integrity": "sha512-TbIGS4xgJoX2i3do417KSaep1uRAW/Lu+WAL2doDHC0D6ummjirVOXU5/7aiZotbQ5p1Zp9tP7U6cYhA0O7M8A==",
6988 6992
       "dev": true,
6989 6993
       "requires": {
6990 6994
         "@cspotcode/source-map-support": "0.7.0",
... ...
@@ -7013,9 +7017,9 @@
7013 7017
       "dev": true
7014 7018
     },
7015 7019
     "typescript": {
7016
-      "version": "4.5.5",
7017
-      "resolved": "https://registry.npmjs.org/typescript/-/typescript-4.5.5.tgz",
7018
-      "integrity": "sha512-TCTIul70LyWe6IJWT8QSYeA54WQe8EjQFU4wY52Fasj5UKx88LNYKCgBEHcOMOrFF1rKGbD8v/xcNWVUq9SymA==",
7020
+      "version": "4.6.2",
7021
+      "resolved": "https://registry.npmjs.org/typescript/-/typescript-4.6.2.tgz",
7022
+      "integrity": "sha512-HM/hFigTBHZhLXshn9sN37H085+hQGeJHJ/X7LpBWLID/fbc2acUMfU+lGD98X81sKP+pFa9f0DZmCwB9GnbAg==",
7019 7023
       "dev": true
7020 7024
     },
7021 7025
     "uglify-js": {
... ...
@@ -22,11 +22,11 @@
22 22
     "release": "standard-version"
23 23
   },
24 24
   "devDependencies": {
25
-    "@commitlint/cli": "^16.2.1",
25
+    "@commitlint/cli": "^16.2.3",
26 26
     "@commitlint/config-conventional": "^16.2.1",
27 27
     "husky": "^7.0.4",
28 28
     "npm-run-all": "^4.1.5",
29
-    "prettier": "^2.5.1",
29
+    "prettier": "^2.6.0",
30 30
     "prettier-package-json": "^2.6.3",
31 31
     "scrivano": "^0.1.0",
32 32
     "standard-version": "^9.3.2"